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Installing and using ESPRIT

Lesson objectives
At the end of this lesson, you will know how to:

• Install ESPRIT

• Start ESPRIT and open a document

• Copy the lesson files for this guide to your hard drive

• Find out about the Software Maintenance Contract (SMC) program

• Get answers to your questions

• Gain access to additional resources that help you become successful with ESPRIT
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Instal l ing ESPRIT
ESPRIT is installed from a DVD that has been shipped to you, along with this guide and installation instructions. You 
will need the following information provided on the ESPRIT DVD case: Customer Code and License Serial Number.
In the event that you cannot find your DVD case, your Customer Code and License Serial Number can be obtained by 
e-mailing your contact information, including Company Name, to esprit@dptechnology.com. For faster access, this 
information can also be obtained by logging onto ESPRITWeb (https://ew.dptechnology.com/ew/login/login.asp) and 
selecting ‘My Account’ on the top menu bar.
Before you begin, make sure the date is set correctly on your computer. If the system date is changed after ESPRIT 
is installed, it can cause damage to your locking device (hardware key) and render ESPRIT inoperative. Your ESPRIT 
software will not work again until a replacement hardware key and new password can be shipped to you at your 
expense. Replacement of hardware keys is not covered by Software Maintenance Contracts.

1. Insert your ESPRIT locking device, normally a hardware key (security dongle) provided by DP Technology, into 
the appropriate USB or parallel port on your computer. If you have a parallel port security dongle, plug it into 
the primary parallel port (LPT1) at the back of your computer. Do not plug it into a serial port.

2. Insert the ESPRIT installation DVD into your DVD drive.

3. Follow the installation instructions to perform a new installation of ESPRIT or to upgrade from a previous 
version of ESPRIT.

Using ESPRIT
ESPRIT is a single instance application and does not support multiple instances.
To start a new session of ESPRIT, do one of the following:

• Double-click the ESPRIT icon on your desktop

• Click the Start menu and then select All Programs » DP Technology » ESPRIT
New ESPRIT documents are based on templates. Each time you start ESPRIT, you can choose an existing template or 
open a blank document that uses the system defaults.
Figure 1. New document from a blank document.

To save a document for the first time, click File > Save and then browse to the location where you want to save your 
file. ESPRIT automatically saves files in the .esp file format.
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Copy the lesson f i les
The files for the lessons in this guide are available on the ESPRIT DVD in the Get Started folder. The files are also 
available for download from ESPRITWeb » File Library » ESPRIT 20xx.
Copy the entire Get Started folder to the default location for ESPRIT files on your computer.
When ESPRIT is first installed, the default location for ESPRIT files is: C:\Users\username\Documents\DP 
Technology\ESPRIT\Data\Esprit _ Files

If the default location for your ESPRIT files has been changed in ESPRIT Options, copy the files to the new location.

Sof tware Maintenance Contract (SMC)
ESPRIT SMC delivers the latest available CAM technology and access to live technical support.
Participants receive...

• Continuous access to the latest software updates

• Live technical assistance provided by factory-certified ESPRIT Application Engineers (AEs)

• Round-the-clock support via ESPRITWeb

• Unlimited access to a variety of resources and discussion forums on ESPRITWeb

ESPRIT Suppor t
ESPRIT Support is available online, by e-mail and by phone.

• To submit an incident online, log in to ESPRITWeb and click the SupportWeb tab to create a new incident. When 
submitting an incident online, you have the opportunity to upload files that demonstrate your issue. 

• You can also ask for help via e-mail. Please e-mail all support requests to support@dptechnology.com. Again, please 
include any files that would help us diagnose the problem. Your e-mail request will be logged into the SupportWeb 
by one of the support coordinators and will be assigned to the next available application engineer.

• To ask for help by phone in North America, D.P. Technology provides a toll-free number for support. If you call 
800-627-8479 and press 3 for support, you will be directed to a support coordinator who will log your request 
and assign it to the next available application engineer. Outside the USA, please contact your reseller or your 
nearest DP Technology office. For a list of offices in Asia and Europe, please visit http://www.espritcam.com/
company/contact.

Addit ional resources
With ESPRIT as your programming solution, you belong to a worldwide community of manufacturers supported by 
a network of resellers, educational institutions and DP Technology offices. The strength of our community enables 
every ESPRIT customer to make the most of their software and machine-tool investments.

ESPRITWeb

Access online resources and discussion forums on ESPRITWeb. To register or log in, visit https://ew.dptechnology.
com/ew/login/login.asp.

• Share ideas and network in discussion forums

• Browse the Post Library

• Browse macros and add-ins in the File Library

• Download additional tutorials from ESPRIT@Work

• View ESPRIT Webinar Videos

• View short videos from the "In Your Corner" section of the ESPRIT de Corps newsletter
ESPRITWeb is available only to registered ESPRIT users who have an active Software Maintenance Contract (SMC).

mailto:support@dptechnology.com
http://www.espritcam.com/company/contact
http://www.espritcam.com/company/contact
https://ew.dptechnology.com/ew/login/login.asp
https://ew.dptechnology.com/ew/login/login.asp
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Professional Training

DP Technology offers customer training around the world, where instruction is offered for all machining disciplines.
To see a schedule of training classes, visit http://www.espritcam.com/support/training. 

ESPRIT World Conference

DP Technology hosts annual gatherings of ESPRIT customers, developers, resellers and manufacturers from around 
the world.

• Technical Sessions: Participate in targeted tracks and hands-on training sessions. Conference topics cover a broad 
range of tools, processes, technologies, and techniques.

• General Session: Preview the latest ESPRIT technology and be inspired by insightful and visionary keynote 
presentations

• Customer Workshops: Meet face-to-face with an ESPRIT product engineer in a semi-private setting where they 
answer questions specific to your ogranization.

• Network: Network with peers and industry experts to maximize your learning experience. Catch up with old 
friends and meet DP Technology staff at the Welcome Reception, meet new people and colleagues at breakfast and 
lunch, and relax at a hosted event.

To learn more, please visit http://www.espritworldconference.com/.

http://www.espritcam.com/support/training
http://www.espritworldconference.com
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Getting to know the workspace

Lesson objectives
At the end of this lesson, you will know how to:

• Open an ESPRIT file

• Navigate the ESPRIT workspace

• Access commands on the menus and toolbars

• Manipulate the display of models in the graphics area

• Use the Project Manager and Property Manager

• Set your preferences in ESPRIT Options
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Workspace overview
The ESPRIT graphical interface allows fast and easy access to commands while giving you the maximum screen 
area to view your work.
The default workspace layout includes:

1. Menus and toolbars along the top of the screen.

2. A Smart Toolbar that provides quick access to commands by grouping them in the logical flow of your work. 
Geometry, features, dimensions, tools, machining operations, simulation.

3. A graphics area where you can view your work. This is the largest area of the screen

4. A Prompt area at the bottom left of the screen that displays messages that tell you what to do next. Always pay 
attention to what the prompt is telling you.

5. A Status area at the bottom right of the screen that provides dynamic information about the current work 
environment. As you select commands or move the cursor, the information is constantly updated.
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Two specialized windows provide an excellent way to manage your work.

1. The Project Manager consists of a tabbed set of windows that list every feature, cutting tool, and machining 
operation in the current session. The Project Manager lets you manage, sort, and reorder these items. To view 
the Project Manager, press the F2 key or click Project Manager on the View menu.

2. The Property Manager displays the specific properties of any item selected in the graphics area or the Project 
Manager. The types of properties displayed depend on the type of item selected. To view the Property Manager, 
click Properties on the View menu or hold down the Alt key as you press Enter.

Open an ESPRIT f i le
You will now start ESPRIT and open a file that has a typical milled part with toolpath already created. You will use 
this part to learn how to manipulate the view.

1. On the desktop, double-click the ESPRIT icon.

If you do not see the ESPRIT icon on your desktop, choose Start > All Programs > DP Technology > ESPRIT > 
ESPRIT.

2. A screen displays information about your license and the version of ESPRIT. Review the information and click 
OK.

3. You are prompted to select a template file for your new document. Make sure <Blank Document> is selected and 
click OK.

The <Blank Document> option opens a new file that uses the ESPRIT defaults. A template file contains user-
defined elements and settings for the way you machine parts at your company.

As you become more familiar with ESPRIT, you can create templates that include regularly used tools, machine 
setup configurations, simulation settings, repeated geometry, and KnowledgeBase settings.

4. Click the File menu and then click Open and navigate to the folder Get Started\01-Workspace.
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5. Select the file Workspace.esp and click Open.

6. Click Zoom to Fit All to fit all visibile elements on the screen.

Zoom the view
The View toolbar provides common tools for manipulating the view. You can also control how solid models are 
displayed with shading options.
Figure 1. The View Toolbar

Commands displayed on the View toolbar include:

• Redraw

• Zoom to Fit All

• Zoom

• Zoom Previous

• Zoom Dynamic

• Rotate

• Pan

• View Shaded Wire

• View Shaded

• View as Hidden Wireframe

• View as Wireframe
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Zooming lets you enlarge the view to get a closer look at your work. You will learn several techniques for zooming 
the view in and out.

1. Click Zoom on the View toolbar. The cursor changes to a magnifying glass.

2. Hold down the left mouse button as you drag a diagonal bounding box around any area of the model you want to 
enlarge.

Notice that the pointer is still in Zoom mode. Zoom stays active until you disable it.

3. Press the Esc key to exit zoom mode.

Note: Clicking another command will also exit zoom mode.

4. Now press the F6 key to fit all elements back on the screen.

Note: F6 is the keyboard shortcut for the Zoom to Fit command.
An alternative to using the zoom commands on the View toolbar is to use the scroll wheel on your mouse.

1. Place your cursor to the right side of the screen.

2. Roll the scroll wheel forward to enlarge the view and roll it backward to shrink the view.

Notice that the zoom is centered around the location of the cursor.
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3. Click Zoom to Fit on the Heads-Up View toolbar.

4. Now place your cursor over one of the holes in the model and scroll forward to zoom in from that position.

5. Roll the wheel backward to zoom out.

6. Instead of rolling the mouse wheel, you can zoom more slowly by holding down the  Shiftkey and the middle 
mouse button (scroll wheel) at the same time. Then drag the mouse forward and backward.

You can also use keys on the keyboard to zoom the view. When the keyboard is used, the view is zoomed from the 
center of the screen.

1. Press F6 to fit the view.

2. Hold down the Shift key and press the Up arrow to zoom in from the center of the screen.

3. While still holding down the Shift key, press the Down arrow to zoom out.



Getting to know the workspace  | 11Get Started with ESPRIT

Pan and rotate the view
Panning lets you drag the view in any direction. Rotating the view lets you view your work from different angles.

1. Click Pan on the View toolbar. The cursor changes to a hand.

2. Hold down the left mouse button and drag the mouse in any direction.

3. Press Esc to exit pan mode.

4. Instead of using the Pan command, you can just use your mouse. Hold down the middle mouse button (or scroll 
wheel) and drag the mouse to pan the view.

5. Click Zoom to Fit All so the entire model is visible in the screen.

6. Click Rotate on the View toolabar. The cursor changes to the rotation symbol. 

7. Position your pointer on the screen.
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8. Hold down the left mouse button and drag the mouse in any direction. The system calculates a bounding box 
around the model and uses the center point of the box as the rotation point.

Like the Zoom function, you can use keys on the keyboard to rotate the view. The Ctrl key activates the Rotate 
function.

1. Press Esc to exit Rotate mode.

2. Hold down the Ctrl key as you press the middle mouse button (scroll wheel) and drag the mouse in any 
direction.

Hover the pointer over an element to rotate about that element.

3. Now hold down the Ctrl key as you press any of the arrow keys.

The view rotates in 15 degree increments.
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Change the orientat ion of the view
The Layers and Planes toolbar provides six orthogonal views (Top, Front, Left, Right, Back, Bottom) and an 
Isometric view. These views are based on the global XYZ axis.
Figure 1. The Layers and Planes Toolbar

1. In the Views dropdown, click Isometric to change the orientation. The model is fitted automatically to the 
screen.

A Normal view is also provided that lets you change the view to an orientation normal to a selected solid face.

1. On the View menu, click Toolbars and then Standard Views.



Getting to know the workspace  | 14Get Started with ESPRIT

2. Drag the toolbar to the left side of the screen until it snaps to the edge.

3. Click Normal To.

Notice the prompt to select a face or feature.

4. Enable Sub-Elements mode on the Status bar. This mode will let you select a face (sub-element) on the solid 
model.

5. Enable Highlight mode on the Status bar. This mode highlights your selections on the screen.
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6. Select the tilted face on the side of the solid model.

Notice the prompt that asks if this is the correct choice.

7. When the face highlights, press the left mouse button to confirm the selection.

The view is now oriented normal to the face.
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8. To remove the display of the toolbar, right-click anywhere on the toolbar and select Standard Views.

Use masks to show and hide objects in the view
Masks are useful for hiding specific types of elements from display. For example, you can hide all geometric 
elements or just circles.
Items in the Masks dialog are grouped into categories. You can hide or show entire categories or hide and show 
individual types of elements within those categories.
Figure 1. Masks dialog

1. Press Ctrl+M to display the Masks dialog.Note: You can also select Masks from the View menu.

2. Set the view orientation to Isometric.
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3. In the Masks dialog, click Toolpath to hide all toolpath from view.

4. Click the Details tab and then click Line to hide geometric lines and segments from view.
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5. Click the Basic tab and then click Work Plane.

Only elements that lie on the active work plane are displayed. This is useful when you are drawing geometry 
and want to temporarily hide elements on other work planes.

Note: The Parallel Planes option hides all elements that are not on a plane parallel to the active work plane.

6. Click Work Plane again and then click Element Numbers.

Every element in ESPRIT has a name and number. As elements are created, they are assigned the appropriate 
name, such as L for line, and a sequential number. The origin of the global coordinate system is always P0 (Point 
0).

7. Click Element Numbers again to hide the numbers and click Toolpath to show the toolpath.

8. Close the dialog.
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Arrange work panes on the screen
The Project Manager lets you manage features, cutting tools and machining operations.
Figure 1. Press F2 to display the Project Manager

The Property Manager lets you view and modify the properties of elements.
Figure 2. Press Alt+Enter to display the Property Manager.

You can customize your workspace by docking work panes to the top, bottom, left, or right edges of the screen.
Figure 3. To float a work pane anywhere on the screen, drag the title bar onto the graphics area.
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Figure 4. To dock a work pane, drag the title bar to an edge of the graphics area until it snaps to the edge.

Figure 5. You can stack panels on top of each other by dragging one work pane onto another.

Figure 6. To view the properties of an item, select it in the Project Manager or in the graphics area.
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Customize workspace color options
You can customize the colors in the user interface for the background and graphic elements.
To set workspace colors, click the Tools menu and then Options.
Figure 1. ESPRIT Options dialog

The color scheme for a gradient background is defined by Background for the top gradient color and Background 
Gradient for the bottom gradient color.
You can choose from a variety of preset color cubes or define a custom color.
Figure 2. Background color options

Instead of a gradient background, you can display the background as a single color by unchecking Use Gradient.
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Figure 3. Enable or disable a gradient background

You can also customize the default color and style for graphic elements like geometry, features, and grouped items.
Figure 4. Select any item in the list to change its attributes (Line Type, Line Weight, Color).

To save the changes as the default settings for future sessions of ESPRIT, click the Default button at the bottom of 
the dialog and then save the changes as the user defaults.
Figure 5. Save user defaults.

To reset all options to the original system defaults, click the Default button and then reset all options to the 
installation defaults.
Figure 6. Reset defaults.
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Working with selections

Lesson objectives
At the end of this lesson, you will know how to:

• Use the mouse and keyboard to select elements

• Select a group of elements based on user-defined criteria

• Invert the selection of elements

• Filter out unwanted elements using the Selection Filter

• Select end points, mid points and center points using Snap mode

• Confirm the selection of elements using Highlight mode

• Use propagation tools to quickly select faces on a solid model
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Selecting and selection tools
An important task in any CAD/CAM system is the ability to select a variety of elements. A single ESPRIT document 
may include one or more solid models, wireframe geometry, surfaces, and toolpath.
Figure 1. A single ESPRIT documents contains multiple types of elements.

When elements are selected (grouped), they are highlighted in the graphics area.
Figure 2. Selection highlights items in the graphics area.

It is also important to have the ability to select individual components of an element (sub-elements), such as faces on 
a solid model or the endpoint of a line.
Figure 3. Individual faces and edges can be selected on a solid model.

The color and style of grouped items can be customized in ESPRIT Options. To change the style, click Options on the 
Tools menu. Then, on the Attributes page, scroll to the bottom of the list and click Group Items. At the right of the 
dialog, choose a Color, Line Weight, and Line Type for grouped items and click OK to save your preferences.
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Figure 4. The display of selected items can be customized in ESPRIT Options.

Using the mouse and keyboard
Like other Windows applications, you can use the mouse and keyboard to select items.

• Click to select

• Drag a box to select all items inside the box

• Use the Ctrl key to add or remove individual items

• Use the Shift key to add or remove multiple items
To begin, you will open a file that has a solid model and wireframe geometry. You will use this geometry to learn 
how to select different types of elements.

1. If ESPRIT is not already running, start ESPRIT from the desktop icon or from the Windows Start menu.

2. Click Open on the File menu and navigate to the folder Get Started\02-Selections.
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3. Select the file SelectionTools.esp and click Open.

4. Click View > Masks and then clear Solid and Features to mask all elements in those categories. Close the 
dialog.

5. Click Zoom to Fit All.

6. Disable Highlight mode, located on the Status bar at the bottom of the screen. Highlight mode is discussed later 
in this lesson. 

7. Select any element in the graphics area. The element is highlighted in bold.
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8. Now use your mouse to drag a box around several elements.

9. All elements inside the box are highlighted. 

10. Click in an open area of the screen to deselect all elements.

Use the mouse and keyboard together

1. Hold down the Ctrl key as you select individual elements. Each new item is added to the group.

2. Click in an open area of the screen to deselect all elements.

3. Hold down the Shift key as you select an element on the slot profile. All elements that share an endpoint are 
grouped. 
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4. Hold down the Ctrl key as you select an individual element in the group. Only that element is deselected. 

5. Hold down the Ctrl + Shift keys as you select an element in the C-shaped profile. The entire profile is added to 
the group. 

6. Click in an open area of the screen to deselect all elements.

Use the keyboard only

1. Press Ctrl + A to group all elements that are unmasked and in visible layers. In this case, all the geometry is 
grouped.

2. Now select only one element in the graphics area.

3. Press Ctrl + W to "swap" the group. All ungrouped geometry is now grouped. The element you selected is 
ungrouped.

The Group command
The Group command lets you define specific criteria for the items you want to select.
The geometry for the pockets and holes is blue. There is also geometry for the outer profile that is red. You will use 
the Group command to group all the blue geometry and then "swap" the group to select all the red geometry.

1. Click Group on the Edit menu or press Ctrl + G to open the Group dialog. 
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2. Under Type, select Arcs, Circles and Segments.

3. Under Color, enable Selection and click the color preview.

4. Select the blue color cube and click OK. 

5. Click OK to automatically group all arcs, circles and segments that are blue. 
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6. On the Edit menu, click Swap Group or press Ctrl + W to ungroup the blue geometry and group all elements 
that do not match the selection criteria. 

Swapping a group can be useful when you want to delete or modify all elements that do not match a set of 
criteria.

Selection Fi l ter
Use the Selection Filter to select specific types of elements.

1. Click Selection Filter on the Edit toolbar and choose Segment. All items will be filtered except for segments.

2. In the graphics area, drag a selection box around the entire model. Only segments are grouped. 

3. Click Selection Filter again and click Arc to allow the selection of arcs only. 
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4. Hold down the Ctrl key and again drag a box around the model. Now all arcs are added to the group. 

5. Click Selection Filter and choose All to allow the selection of all elements. 

Snap mode
Snap mode lets you recognize the midpoints and end points of lines and segments and the center points of circles 
and arcs as valid point selections.
You can use Snap mode with any command that allows the selection of a point.

1. Make sure Snap mode is enabled on the Status Bar.

2. Click Geometry on the Smart toolbar and then click Line 2.

3. Hover the pointer over the center of a circle or arc. The pointer changes to a center point symbol. 

4. Left-click to select the center point.

5. Hover the pointer over the end point of a segment or arc. The pointer changes to an end point symbol. 
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6. Now hover the pointer near the middle of a segment or arc. The pointer changes to a mid point symbol. 

7. Left-click to select the midpoint and create the segment.

8. Press the Esc key to exit the Line 2 command. Geometry commands stay active until you click another command 
or press Esc.

9. Click Undo to remove the segment. 

Highl ight mode
When multiple elements are close to, or even on top of, each other, Highlight mode will highlight the nearest item 
and ask you to confirm the selection. You can accept the selection or you can reject it and let the system highlight 
the next nearest item.
Highlight mode also displays the name of the element with a letter and number. For example, a point will display as 
P2, a segment as S5, an arc as A10, a circle as C3. Elements are numbered in the order they are created.
The selection zone is limited to a 5 pixel radius around the tip of the cursor. This makes it easier to select the correct 
item with the first click.

1. Enable Highlight mode on the Status bar.

2. Select near the point along the outer boundary. An element and its element name will highlight in the graphics 
area and the system prompts "Is this the correct choice?" 

3. Right-click to answer No.
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4. The next nearest element is highlighted. You can continue to right-click to display and eliminate elements. 

5. Left-click to answer Yes and group the element.
The highlighted name of the element helps you select the correct element. For example, arcs are identified with an 
"A" and circles are identified with a "C".

Select sub-elements of a feature

The ability to select sub-elements on a feature is useful for changing a single property (such as defining one edge of 
a pocket as an open edge).

1. Press Ctrl+M and mask Geometry. Unmask Features. 

2. Select anywhere on the chain feature. The entire feature highlights in the graphics area and the system prompts 
"Is this the correct choice?" 

3. Right-click to answer No. Now the nearest sub-element of the feature highlights and the system again asks if 
this is the correct choice.

4. Left-click to answer Yes.
You can also select several connected sub-elements at once. This is useful for changing the properties of a portion of 
a feature, such as changing the taper angle.
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1. Use Highlight mode to select a sub-element on the chain feature. Be sure to answer Yes to confirm the selection. 

2. Hold down the Ctrl key and use Highlight mode to add a second sub-element to the group. 

3. Now hold down the Shift + Ctrl keys and use Highlight mode to add any element between the two. All sub-
elements between the two are grouped. 

Select sub-elements on a solid model

The ability to select sub-elements on a solid model is extremely useful when you want to machine individual faces. 
You can also select individual edges, all edges that form a loop around a face, and vertexes at the intersection of 
edges.
Depending on the location of the pointer when an item is selected, Highlight mode starts with the most specific 
element and ends with the least specific.
Selection priority on a solid model is:

• Vertex

• Edge

• Face Loop

• Face

• Solid body
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If you select in the middle of a solid face, the face is highlighted first, then the solid model.

1. Click Ctrl+M and unmask Solid. 

2. Select in the middle of a face on the solid model. The face highlights in the graphics area and the system 
prompts "Is this the correct choice?" 

3. Right-click to answer No. Now the entire solid model highlights and the system again asks if this is the correct 
choice. 

4. Left-click to answer Yes.
If you select near an edge, the edge is highlighted first, then the nearest face loop that contains the edge.

1. Select an edge. The edge highlights. 
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2. Right-click to answer No. Now the nearest face loop highlights. 

3. Right-click to answer No. The next face loop highlights. 

4. Left-click to confirm the selection.
If you select near a vertex, the vertex is highlighted first, then the nearest intersecting edge.

1. Select near a vertex. The vertex highlights. 
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2. Right-click to answer No. Now the nearest edge highlights. 

3. Right-click to answer No. The next nearest edge highlights. 

4. Left-click to confirm the selection.

Propagation
Use propagation to quickly group a series of connecting faces on a solid model.
Propagation options are available on the Status Bar. One set of options controls propagation when a face loop is 
selected. Another set of options controls propagation when a solid face is selected. You can also define propagation 
options in ESPRIT Options on the Workspace tab.
Only a few methods are shown in this lesson. For complete information about propagation options, refer to ESPRIT 
Help (press F1 in ESPRIT to access the help system).

Propagate faces using an edge

When the faces you want to group have four non-tangent edges, you can propagate all faces that share an opposite 
edge.

1. Open the file Propagation.esp in the Lesson 02 folder.
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2. Hold down the Shift key and select a vertical edge in the pocket on the top face of the model. 

3. Confirm the selection (left-click). Each face that shares an opposite edge is propagated until all faces sharing 
opposite edges are added to the group. 

4. Now hold down the Shift key and select a horizontal edge in the pocket. 

5. Confirm the selection. This time, faces are propagated along horizontal edges. 

Propagate faces along parametric f low lines

Propagation is very useful for grouping curved faces along parametric flow lines.

1. Click Grouping Properties on the Edit toolbar.
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2. In the dialog, set Face to Along Parametric. 

3. Hold down the Shift key and select a face on the fillet shown below. A preview of the parametric direction is 
highlighted on the face. 

4. Right-click. Now the preview of the parametric direction is in the opposite direction. 

5. Confirm the selection. Faces are grouped along the direction of the selected parametric flow lines. 

Propagate visible faces inside a loop

When a pocket is machined, the tool can only cut what it can reach in a given direction: the visible faces. Limiting 
propagation to visible faces prevents the possibility of selecting "undercut" faces that cannot be machined with a 
standard milling machine or standard cutting tool.
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1. In the dialog, set Loop to Visible Faces in Loop. 

2. Hold down the Shift key and select the closed loop around the pocket on the top face of the model. You might 
have to right-click a few times to select the correct loop. 

3. Confirm the selection. All faces inside the loop are grouped because they are visible along the normal direction 
of the face that contains the loop. 
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4. Now hold down the Shift key and select the closed loop around the pocket on the side face of the model. 

5. Confirm the selection. Notice that the tilted faces are not grouped. These faces cannot be machined along the 
normal direction of the face on the side of the model. 
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Working with geometry

Lesson objectives
At the end of this lesson, you will know how to:

• Set the work plane where geometry will be created

• Draw simple geometry

• Extract geometry and surfaces from a solid model

• Create geometry and simple chain features for machining

• Create curves from solid faces
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Geometry for machining
A basic requirement of any CAD/CAM system is to provide functions that allow the creation of 2-dimensional and 
3-dimensional geometry.
CNC programmers often start with a solid model of the finished design. These solid models rarely have the 
geometry that machinists require for the manufacturing process.
ESPRIT provides geometry creation tools to:

• Extract geometry directly from a solid model

• Generate profiles of a solid model using a slice plane or revolution axis

• Create and edit a variety of wireframe geometry and curves

• Extend, trim, blend, and fillet 3D surfaces

• Split, merge, fillet, and chamfer solids 
For programming jobs where a solid model is not required, ESPRIT also makes it easy to create simple chain 
features instead of geometry for your machining operations. Unlike geometry, features contain machining 
properties like depth and lead-in point.

Draw geometry on di f ferent work planes
When geometry is created, it is drawn on the active work plane. Work planes let you draw geometry on a plane 
other than the default XYZ plane. The location and orientation of the current work plane is shown by the UVW axis 
in the graphics area.

The blue arrow designates the Z (or W) axis; the red arrow designates the X (or U) axis; the green arrow designates 
the Y (or V) axis.
The display of the UVW axis (and the XYZ axis) is controlled on the View menu.

ESPRIT provides three work plane orientations: XYZ, ZXY, and YZX. These predefined planes all start at the system 
origin point (P0).
When a new document is opened, the work plane is set to the XYZ plane by default. Geometry is always drawn on 
the XY plane of the active work plane.

1. If ESPRIT is not already running, start ESPRIT from the desktop icon or from the Windows Start menu.

2. Click File > New.

3. Make sure <Blank Document> is selected and click OK.

4. On the Tools menu, make sure System Unit is set to Metric.

5. Set the view to Isometric.
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6. On the Smart toolbar, click Geometry and then click Circle 1. 

7. The system prompts for a reference element. Use Snap mode to select the origin point of the UVW axis. 

8. The system prompts for a radius value. Type the number 5. As soon as you type a value, the input box displays. 

9. Accept the value by pressing the Enter key.

10. Click Zoom to Fit. 

11. Click Point. 

12. In the dialog box, select Cartesian/Center and then make sure X is 10, Y is 10, and Z is 0 and click Apply. 

13. Change X to -10, Y to -10 and click Apply again.
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14. Close the dialog box and click Zoom to Fit. 

15. Click Rectangle.

16. The system prompts for the first reference point. Select one of the new points.

17. Now the system prompts for the second reference point. Select the other point. 

18. Press the Esc key to exit the command.

Draw geometry on the ZXY plane

Now you will change the active work plane so you can draw geometry in a different orientation.

1. Set Work Plane to ZXY. The active work plane is displayed in bold in the list. 

2. Notice the new direction of the W axis. 
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3. To move the work plane so you can draw geometry at the front of the rectangle, click the Edit menu and then 
click Move Origin Point. 

4. The system prompts for a new origin point. Use Snap mode to select the bottom corner of the rectangle. 

5. Click Zoom to Fit.

6. Click View and click the XYZ Axis to hide the axis and make it easier to see the geometry you will be creating. 

7. Click Horizontal/Vertical Line.

8. In the dialog, select Horizontal. Horizontal lines are drawn parallel to the U (red) axis.

9. Enter a distance of 20 and click Apply.

10. Enter a distance of 0 and click Apply. 
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11. Click Vertical. Vertical lines are drawn parallel to the V (green) axis.

12. Enter a distance of -10 to draw the line below the V axis and click Apply. 

13. Close the dialog.

14. To trim the outer portions of these lines, click Keep. 

15. Select each line inside the portion you want to keep. The rest of the line is trimmed away. 

16. Press the Esc key to exit the command.

Draw geometry on a custom plane

You can also create your own work planes at any position and any angle.

1. Click Work Plane from Geometry. 

2. The system prompts for the first element in the plane. This element defines the U axis of the new work plane. 
Select the segment shown. 
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3. The system prompts for the second element. This element defines the V axis. Select the segment shown. 

4. Click Rotate Work Plane. You will rotate the UVW to have a 60 degree slope away from the box. 

5. Select the segment along the U axis.

6. The system prompts for the rotation angle. Enter 150 (90 degrees plus another 60 degrees). You could also 
enter -210 (180 degrees plus 30 degrees).. 

7. On the Create menu, click Bounded Geometry. This toolbar lets you create segments and arcs.

8. Click Segment 1.

9. Select the segment along the U axis. 
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10. Enter an offset distance of 10.

11. When the system prompts for the direction of the offset, click above the reference segment. 

12. Click Arc 3. You will draw an arc using three reference elements.

13. Select the end point shown, then the new segment, then the other endpoint. The arc is drawn tangent to the 
segment. 

14. Press Esc.

Smash a model to ext ract geometry
When placing machining operations on a solid model, it can be useful to extract geometric information from that 
model such as corner points and boundaries. A solid model can be "smashed" to extract wireframe geometry, points, 
surfaces, or chain features.

1. Open the file Smash.esp in the Lesson 03 folder.

2. Zoom in and use Highlight mode to select the planar face at the top of the cavity. 
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3. Right-click and then click Copy. 

4. In the Copy dialog, set Transformation Type to Smash. When a solid face is selected, the only object that can 
be extracted is a surface. 

5. Click OK to create a surface that matches the solid face. 

6. Hold down the Ctrl key and use highlight mode to group vertexes at the four corners of the solid model and then 
press Ctrl + C to open the Copy dialog box. 
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 X Make sure Transformation Type is still set to Smash and click OK. A point is created on each vertex.You can 
use the Manual Chain command on the Feature tab to select each point to create a closed boundary around the 
model.

7. Group the face loop around the outside of the cavity. 

8. Press Ctrl + C and then click OK to create a chain feature around the loop. 

 X A chain feature can also be created by grouping a face loop and then clicking the Auto Chain command located 
on the Feature tab. However, Auto Chain will automatically calculate the depth, draft angle and cut side from the 
selected solid elements. Auto Chain generally uses the longest length of the shortest face in the loop.

9. Select the edge of a fillet on a corner of the model. 
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10. Press Ctrl + C and click OK in the dialog to extract an arc.

11. Use Highlight mode to select the arc and then open the Property Manager to view the radius and other 
properties of the arc. 

Create curves f rom sol id faces
When working with sculpted surfaces and multi-axis machining, curves can be created along the parametric flow 
lines of solid faces and surfaces. These curves can be used to control the path for the cutting tool or a parametric 
curve can be offset from the surface and used to control the orientation of the tool axis.

1. Open the file ParametricCurve.esp in the Lesson 03 folder. 

2. On the Create menu, click Curves to display the toolbar. 

3. Click Curve From Surface. 
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4. In the dialog box, click the selection arrow and then select a face on one of the channels. 

5. Make sure Curve Type is set to Parametric Curve.The face is highlighted and a UVW axis displays the 
direction of the flow lines. The red arrow indicates the U direction, the green arrow indicates the V direction, 
and the white arrow indicates the direction of the surface normal.

6. Set Parametric Direction to V Direction to see a preview of the parametric curve. 

7. Set Parametric Direction to U Direction to see a preview of the curve in the opposite direction. 

8. Change Curve Position Percent to 50 to place the curve in the middle of the face. 
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9. Set Offset Curve to Yes. Additional options are displayed. 

10. Set Offset Distance to 40. The curve is offset in the direction of the surface normal. The direction of the offset 
can be reversed in situations where the offset is in the wrong direction. This curve can be used to control the 
orientation of the tool axis as the tool moves along the surface. 

11. Click OK to create the curve.
You already know that an edge can be smashed to extract wireframe geometry. When an edge is non-planar, a 
3-dimensional chain can be extracted without creating the wireframe first.

1. Select an edge on the channel. You can select any number of edges. 

2. On the Smart toolbar, click Feature and then click Auto Chain. 
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3. A 3D chain is created along the edge. 

Draw hole pat terns
Holemaking is one of the most common types of machining. Holemaking requires knowledge of the machining 
properties for each hole (diameter, depth, countersink, counterbore, and so on) and the coordinate location of 
each hole. It is also an advantage to optimize the path from one hole to the next to make the cycle time for drilling 
operations as fast as possible.
For situations where you only need to drill holes, a solid model is not required. ESPRIT lets you create PTOP (point-
to-point) features that include the coordinate location of every hole. You can then apply the same diameter and 
depth to every point location in the feature instead of drawing circle after circle.

1. Click File > New.

2. Make sure Tools > System Unit is set to Metric.

Set the grid spacing

To make it easier to draw new geometry, you can select grid points in the graphics area.

1. Click Tools > Options.

2. Click the Input tab.

3. Make sure Enable Grid Mode is selected.

4. Change the grid spacing to 25 mm for X, Y, and Z. 
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5. Click OK.

Draw a circular hole pattern

1. On the Smart toolbar, click Geometry and then click Point Array. 

2. In the dialog box, select Circle for the shape of the array.

3. For the number of holes in the array, enter 6.

4. For the radius of the array, enter 50.

5. For the angle between points, enter 360/6. Input fields let you enter a mathematical expression as well as a 
value.

6. For the start angle of the array, enter 0.

7. Select Create PTOP Feature. The system will create a single PTOP feature that connects all the points in the 
array. 

8. Notice the prompt at the bottom left of the screen "Select reference point". Select the origin of the UVW axis 
(P0) to create the points and the feature. 

Draw a linear hole pattern

1. In the dialog box, select Line. Notice that the options change.

2. For the number of points, enter 3.

3. For the distance between points, enter 75.
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4. For the angle, enter 0 to create the points along the U axis. 

5. In the graphics area, move the cursor until the coordinates in the Status Bar read -75, 0, 0. 

6. Click the grid point to create the points and feature. 

7. Close the dialog box.

Add machining proper ties to the circular hole pattern

1. If the Property Manager is not shown, press Alt+Enter.

2. In the graphics area, group the PTOP for the circular hole pattern. 

3. Expand the section for Machining properties. Notice that machining properties for a PTOP feature include 
depth, diameter, countersink, and counterbore. 
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4. Click in the value column for Diameter and change the value to 6. Press the Enter key to update the feature.

5. Change the Depth property to 10.

6. Change the Through property to Yes.

7. Set the view to an Isometric orientation to see your changes. The new properties are applied to every point 
location in the feature. 

Add machining proper ties to the linear hole pattern

1. In the graphics area, group the PTOP for the linear hole pattern. 

2. In the Property Manager, change the property for Diameter to 12.

3. Change Depth to 10.

4. Change Chamfer Diameter to 15 and Chamfer Angle to 60.
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5. Set Through to Yes. 

Draw a rectangular hole pattern on a new work plane

1. Click Parallel Plane. 

2. For the U translation and V translation, enter 0.

3. For the W translation, enter 25 to move the plane up. 

4. Click Point Array again and then select Grid.

5. For the number of points in the first direction, enter 3.

6. For the distance between points, enter 100.

7. For the angle in the first direction, enter 0.

8. For the number of points in the second direction, enter 2.

9. For the distance between the points, enter 150.

10. For the angle in the second direction, enter 90.

11. Make sure Create PTOP Feature is still selected. 
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12. In the graphics area, move the cursor until the coordinates in the Status Bar read -100 mm, -75 mm, 25 mm and 
click the grid point. 

13. Close the dialog box.

14. In the Work Planes list, notice that the system created a new work plane automatically for the feature. 

Add machining proper ties to the rectangular hole pattern

1. In the graphics area, group the PTOP for the rectangular hole pattern.

2. In the Property Manager, change the property for Diameter to 8.

3. Change Depth to 25.

4. Change Bore Diameter to 12 and Bore Depth to 6.

5. Set Through to Yes. 

Reset the grid spacing to the system defaults

1. Click Tools > Options.

2. Click the Default button and then select Reset all to installation defaults.

3. Click OK.

4. Click OK to close the Options dialog.
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Working with features

Lesson objectives
At the end of this lesson, you will know how to:

• Import a 2D drawing and get it ready for machining

• Import a solid model and get it ready for machining

• Create simple chain features and add machining properties

• Create hole features

• Modify the shape of a chain feature
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Feature Overview
Features are an integral component to the machining functions in ESPRIT and serve several purposes: 

• Features describe machinable shapes. Machinable shapes include pockets, holes, profiles, faces, and so on. A set of 
features can be used to describe the shape of an entire part.

• Features provide a single source of information about how to machine a part. Features have machining properties 
that provide information about the area where material will be removed, the orientation of the tool axis, the 
maximum depth for cutting passes, draft angles along walls, entry and exit points, and much more.

• Feature properties are linked to the machining technology in ESPRIT. The system reads the machining properties 
of the selected feature and loads the appropriate values onto the operation technology page. This saves time and 
prevents the errors caused by entering values manually.

• Toolpath and features are linked. If the shape or properties of a feature are modified after toolpath is applied, the 
toolpath can be updated (rebuilt) with a single click to reflect those changes.

• Features help automate machining processes. An entire machining process can be associated with a certain type 
of feature. For example, a drilling and tapping process can be associated to threaded holes.

Chain Features

Chain features are quite simple and are used when you want the cutter to follow a defined path or when you want 
to contain toolpath inside a boundary. A chain feature defines the start location, direction, and end location for a 
cutting path.

Chains are typically used for contouring or profiling operations. In most cases, the tool can be centered on the chain 
feature or offset to the right or left.

Hole Features

Hole features define the location and orientation of holes and have unique properties for threads, chamfers, counter 
bores, bottom angle, and whether the hole is through or blind. Hole features are used for drilling operations, 
threading, and spiraling.
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Feature Set

A Feature Set contains a collection of individual features that comprise an area to be machined. A feature set is 
represented by a folder in the Feature Manager. A feature set is typically a Part feature that contains all features on 
the part or a Pocket feature that contains all sub-pockets or islands inside a boundary. The entire feature set can be 
machined or operations can be applied to individual features in the set.

FreeForm Features

FreeForm features are used for surface machining 
and contain complex solid faces and surfaces. Inside 
the feature, the faces to be machined are designated 
as Part surfaces (shown in green) and the faces that 
cannot be touched by the tool are designated as Check 
surfaces (shown in red). Faces that define the shape of 
the stock can also be added.

Ruled Features

Ruled features define walls that are cut with the side 
of the tool rather than the tip, such as swarf milling or 
rotary wire EDM. Ruled features contain an upper and 
lower profile and synchronization lines between the 
two profiles.

Draft Conic and EDM Ruled Features

Draft Conic features are used exclusively for wire EDM 
operations to define a die, punch, hole, open profile or 
turning profile. Draft Conics have properties for 2-axis 
EDM operations such as thread points, the height of 
land and taper areas, corner styles, gradual tapers and 
constant tapers.

EDM Ruled features are used for 4-axis wire EDM 
operations. Ruled features have separate properties 
for the UV and XY profiles, the match lines between 
the two, and the start and end points for the thread 
line.
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Impor t a 2D drawing and get i t ready for machining
Even though engineers have moved primarily to representing their designs with solid models, there will always 
be a place in manufacturing for 2D drawings and geometry. Some designs are more easily represented with 2D 
geometry, such as contours or hole patterns. And many companies have legacy drawings that have not been 
converted to 3D models. 
You will start by opening an AutoCAD file in ESPRIT.

1. Click File > Open.

2. Browse and select the file 2Ddrawing.dxf in the Lesson 04 folder.

3. Click the Options button.

4. Make sure File Unit is set to Metric. 

5. Click OK to close the Options dialog.

6. Click Open to import the drawing.
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7. Click Zoom to Fit.

8. On the Status bar, make sure HI mode and SUB-ELEMENTS mode are enabled.
This drawing already has layers that were created in AutoCAD. When a CAD file is imported, the layers are imported 
also. This drawing has elements that you do not need for machining operations, such as the drawing border and title 
box. You can hide these elements so you only see the geometry for the part.

1. Click Layers.

2. Uncheck the layers Border (ISO) and Title (ISO) to hide those elements from view and then click New.
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3. Type the name Features and click OK. The new layer is activated automatically. All new elements will be 
assigned to this layer. Close the Layers dialog.

The origin point in the AutoCAD drawing is not located on the part geometry. To make this part easier to machine, 
you will move the origin point to the lower left corner of the part boundary since this is a good touch-off location for 
the machinist.

1. Click Edit > Move Origin Point.

2. Select the snap location at the lower left corner of the part boundary. The origin of the XYZ plane is moved to 
this point.

Create a Hole feature from 2D circles

Points, circles, and arcs can be used as input for Hole Feature Recognition. However, you will need to edit the feature 
to add machining properties.

1. On the Smart toolbar, click Feature and then Hole Feature Recognition. 
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2. Click the arrow button next to Max Diameter and select an inner circle from one of the drilled holes. 

3. Group all the geometry and click OK to create the feature. Circles with a diameter within the minimum and 
maximum range are recognized. 

4. Select the Simple Hole feature in the Feature Manager.

5. In the Property Manager, change Chamfer Diameter to 7.

6. Change Chamfer Angle to 90.

7. Change Depth to 15.

8. Change Bottom Angle to 118.
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9. Change the Name property to update the depth from 10 to 15.

Create chain features for a pocket

You can create simple 2D chain features from wireframe geometry and edit the properties of the feature to add 
3-dimensional properties for machining.

1. Hold down the Shift key and select a single element on the pocket boundary. All connected geometry is grouped. 
Now hold down the Ctrl key and Shift key together and select a single element on the island boundary. That 
geometry is added to the group.

2. On the Feature tab, click Auto Chain. 

3. In the Feature Manager, use the Ctrl key to group the two chains.
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4. Change the Depth property to 18. Both features are updated.

5. Group the chain for the pocket boundary and change Cutting Side to Right and press Enter. Notice that the 
property for Material Removal changes to Inside.

6. Group the chain for the island inside the pocket and change Cutting Side to Left and press Enter. Material 
Removal for this chain is now Outside.

Create a chain feature with open edges

An open pocket is a pocket with at least one edge that is not bounded by a wall, allowing the tool to enter the pocket 
from the side and cross the open edge during the operation.

1. Hold down the Ctrl key as you select each element in the open pocket. 

2. Click Auto Chain.

3. Change the Depth of the feature to 24 and Cutting Side to Right so that Material Removal is Inside.

4. Use the Ctrl key and Highlight mode to group the three sub-elements on the outside edges of the open pocket. 
Be sure you do not group the segments. 
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5. In the Property Manager, expand the Attributes properties and change Open Edge to True. If you mask the 
geometry, you will see that the open edges are displayed as dashed lines. 

Create a chain feature on the outside boundary of the par t

A chain around the outside boundary of the part can be used for a facing operation or contouring operation.

1. If necessary, unmask Geometry.

2. Click Manual Chain.

3. Use Snap mode to select the four corners of the part boundary in a counter-clockwise direction.

4. Change the Depth to 30 and Cutting Side to Right so that material removal is on the outside. This geometry is 
now ready for machining.



Working with features  | 71Get Started with ESPRIT

Create simple features on a sol id model
This lesson will show you how to extract geometry from a solid model and use it to create new geometry. You will 
also learn how to create chain features for pocketing, contouring and facing operations.

1. Click File > Open and select the Parasolid file Trunnion.x_t in the Lesson 04 folder. 

2. Click the Options button and select Create Wireframe. When the model is opened in ESPRIT, wireframe 
geometry will automatically be extracted along edges.

3. Click OK to close the dialog and then click Open.

4. 
You will start by creating a feature that defines the open area above the two prongs. This space must be enclosed by 
a feature before a machining operation can be applied to remove the material.

1. On the Smart toolbar, click Geometry and then click Point.

2. In the dialog box, select Intersect.

3. Select the two segments shown below to draw a point where the two segments intersect. 
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4. Use the same technique to draw a second point on the opposite side. Close the dialog box. 

5. Click Feature on the Smart toolbar and then click Manual Chain. Create the chain shown below by selecting 
end points and the intersection points. 

6. Select the chain and then select the Depth property in the Property Manager. Instead of entering a value, click 
the digitize button and then select the end point of the segment shown below to input the value. 
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7. Select the three sub-elements of the chain shown below (use Highlight mode and the Ctrl key). Notice that the 
only property available is Attributes. Change the Open Edge property to True. The sub-elements are now 
displayed with dashed lines. When a pocketing operation is applied to the feature, the tool will be allowed to 
cross over the open edges. 

The next step is to define the pocket area below the feature you just created. You will use Pocket Feature 
Recognition on selected faces.

1. Select the planar face shown and then click Pocket on the Feature toolbar.

2. Notice that the feature extends to the top of the part. When a bottom face is selected for Pocket Feature 
Recognition, the system automatically finds the height of the tallest adjacent face. Click Undo. 

3.  Now hold down the Ctrl key and select the wall face shown to add it to the group. Click Pocket again. Now the 
system recognizes the height of the selected face.

Now you need to define the area between the two prongs so that a contouring operation can be applied in the 
future. You will use Wall Feature Recognition to automatically calculate the highest and lowest limits of all the 
selected wall faces.
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1. Hold down the Shift key and select a single vertical edge between the two prongs. All faces that share an edge 
are propagated.

2. Click Wall on the Feature toolbar. A profile feature is created automatically using the highest and lowest points 
on the selected faces. 

Next you will learn how to create geometry and features on a tilted face.

1. On the Smart toolbar, click Geometry and then click Work Plane from Geometry. Select the inclined face.

2. Click Feature, then Manual Chain and create a chain around the tilted opening by selecting the end points 
of the segments. When a facing operation is later applied to the feature, the toolpath can be extended to cut 
outside the boundary.
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3. Notice that the new work plane was added to the list. This work plane is associated to the feature you just 
created. When a machining operation is applied to the feature, the tool axis will be aligned with the W axis of 
the associated work plane.

You can easily create a single planar boundary around the outside of complex models by projecting a silhouette of 
the part profile onto a plane. The boundary can then be used to rough the outer contour of the part.

1. Set the work plane back to XYZ.

2. Click Layers and create a new layer called Boundary.

3. Click Part Profile. You will project a silhouette of the part onto the active work plane to create a boundary 
feature.

4. Select the solid model and then choose Shadow for Profile Type and select Create chain on profile.
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5. Click OK to create a chain around the outside boundary of the part. Notice that chains are also created for the 
holes that go through the model.

6. In the Layers dialog, clear the Default layer so that only the Boundary layer is visible. You will edit the chain to 
make it more suitable for a rough contouring operation.

7. Now you will remove some of the elements from the feature. Select the element shown below. When the feature 
highlights, right-click to highlight just the sub-element.

8. Hold down the Ctrl key and select the sub-element on the opposite side.

9.  Now hold down the Shift + Ctrl keys and select a sub-element in the middle. All connected sub-elements 
between the first two elements are highlighted.
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10. Press the Delete key. The selected sub-elements are removed and the remaining sub-elements are reconnected.

11. Display the Default layer again so that all elements are visible and change the Depth of the profile feature to 30.
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Traditional turning

Lesson objectives
At the end of this lesson, you will know how to:

• Set up a 2-axis turning machine

• Add turning tools

• Recognize turning features on a solid model

• Rough the face, OD, and ID of bar stock

• Drill on the centerline

• Rough and finish grooves

• Cut threads

• Perform a cutoff
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Impor t a turning par t and get i t ready for machining
Before you can start creating turning operations, you need to define your part and stock. ESPRIT maintains 
awareness of the stock model as turning operations are applied. As stock is removed, the stock model is updated 
and new turning operations generate toolpath only in areas where stock remains.

1. Start a new session of ESPRIT.

2. On the Tools menu, make sure System Unit is set to Metric.

3. Click File > Open.

4. Navigate to the folder 05-Turning and open the file TurnedPart.x_t.

5. On the Status bar, make sure HI mode and SUB-ELEMENTS mode are enabled.
For this part, you will define the stock as a cylindrical bar. Bar stock for lathes is defined in SolidTurn Machine 
Setup.

1. On the Smart toolbar, click Switch to SolidTurn. Notice that lathe stock is now displayed in the graphics area. 
Also notice that the work coordinate in the Feature Manager changes to YZX. Because ESPRIT supports both 
milling and turning, the X axis is used as the turning axis in ESPRIT.
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2. Click Common Machining and then click Machine Setup. 

3. Change Bar Diameter to 60.

4. Change Total Bar Length to 81.

5. Change Part Stock Length to 50.

6. Change Start Position Z to 1. This moves the start position of the bar forward to create 1 mm stock allowance 
on the face of the part.

7. Click OK to update the stock and close Machine Setup.

Mount tools on the turning machine
Commands in the Tool Manager let you create milling and turning tools.

You choose the type of tool you want to create, choose the turret and station where the tool will be mounted on the 
machine, and define dimensions for the insert and shank.
You will start by modifying the standard machine setup in ESPRIT to change the configuration of the turret and add 
more tool stations. The default turret in SolidTurn Machine Setup is an index turret with six tool stations. You will 
add another six stations for a total of twelve.

1. Click Common Machining and then click Machine Setup. 



Traditional turning  | 81Get Started with ESPRIT

2. Click the Assembly tab and select IndexTurret-1 to view its properties.

3. Change Moves to Tool Change to X First.

4. Verify that Moves From Tool Change has changed to YZ Next X.

5. Change Home Position X Y Z to 500, 0, 400.

6. Expand IndexTurret-1 in the tree to view the number of tool stations.

7. Click the New Station button until there are a total of 12 tool stations on the turret. Notice that the tool change 
angle and tool position for each new station is set to zero. Instead of entering properties for each tool station 
manually, you will learn how to configure the tool stations automatically.
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8. Select IndexTurret-1 in the tree and then click the Geometry button.

9. In the dialog, change Turret Diameter to 420 and Turret Width to 0 and click OK.

10. Click the Configure Stations button to configure the new tool stations on the updated turret geometry.

11. Now select Station:12 in the tree and notice that the tool change angle and tool position have been set.

12. Click OK to save your changes and close Machine Setup.

Create turning tools

The first tool you create will be used for roughing on the face of the part. It will be mounted in a vertical orientation 
on the turret, facing the main spindle.

1. In the Tools Manager, click Turning Tools and then select Turning Insert.

2. From the dropdown menu, click System Default All to reset all parameters to the system defaults.
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3. Click the General tab and change the following parameters:

• Tool ID = OD Rough

• Simulation Cut Color = Yellow

• Click the Settings tab and change the following parameters:

• Turret Name = IndexTurret-1

• Station Name = Station:1

4. Click the Insert tab and change the following parameters:

• Tolerance = M

• Type = G

• Nose Radius = 0.8

• Thickness = 3
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5. Click the Shank tab and change the following parameters:

• Style = L-5 Lead Facing

• Shank AxB = 20 - 20.00 x 20.00

• C = 120

• F = 22

6. Click OK.
This next tool is a full radius grooving insert that will be used on the inner diameter of the part. It will have a round 
shank and be mounted in a horizontal orientation on the turret.

1. Click Turning Tools and select Grooving Insert.

2. Click System Default All.

3. On the General tab:

• Tool ID = ID Groove R4

• On the Settings tab:

• Turret Name = IndexTurret-1

• Station Name = Station:8

• Orientation = 2H
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4. On the Insert tab:

• Shape = Full Radius

• Nose Angle = 90

• Nose Radius = 4

• Size = 10

• E = 8.5

• Thickness = 2

5. On the Shank tab:

• Shank Type = Round Shank

• Tool Diameter = 10 - 10.00

• A = 16

• C = 55

• F = 13.5

6. Click OK.

Create a twist drill

1. Click Milling Tools > Drill.

2. Click System Default All.

3. On the General tab:

• Tool ID = Drill 21 x 70L

• Simulation Cut Color = Orange

4. On the Settings tab:

• Turret Name = IndexTurret-1

• Station Name = Station:12

• Axis Orientation = Z+

5. On the Shank tab:

• Shank Diameter = 21

• Tool Length = 70

• Cutting Length = 60

6. On the Cutter tab:

• Tool Diameter = 21

7. On the Extension tab:

• Overall Length = 70

8. Click OK.

Import tools from an external f ile

Any cutting tools in the Tool Manager can be saved to an ESPRIT Tool Library (*.etl) file. One or more tools can be 
selected and saved to a file. The tools in the file can then be imported into any other ESPRIT document.
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1. In the Tool Manager, click File > Open.

2. Open the file TurningTools.etl, located in your lesson folder. The tools in the file are added to the tool list in the 
Tool Manager.

Create features for turning
You will use the Turning Feature Recognition command on the Accessories toolbar to analyze the shape of the solid 
model to find internal and external profiles. Turning Feature Recognition rotates the part around the turning axis 
(the X-axis in ESPRIT) to find the true turned profile.

1. Press Ctrl+M to display the Masks dialog, click the Details tab and then select Lathe Stock to mask the display 
of the stock. Close the dialog.

2. Make sure the Accessories toolbar is visible. If the toolbar is not displayed, click Tools > Add-In to display the 
dialog. Choose Accessories Add-In, select Loaded and Load on Startup, and then click OK.

3. On the Accessories toolbar, click Turning Features.
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4. Use the default settings in the dialog as shown below.

5. Select the solid model and click Apply. Turning features are recognized and assigned an appropriate name and 
work coordinate.

6. Close the dialog.
Chain features can be modified to add new elements, delete elements, reverse the direction, and change the start 
point. You will learn how to modify the chain on the OD profile to replace the elements in the groove with a straight 
segment over the top of the groove.

1. On the Smart toolbar, click Features and then click Manual Chain. The Manual Chain command can be used to 
modify chain features as well as create them.
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2. Select the feature on the OD. The chain can now be edited to add and remove elements. The cursor is attached to 
the end point of the chain.

3. On the Edit Feature toolbar, click Move Back.

4. Select the feature sub-element shown to remove all elements between that element and the end point of the 
chain.

5. Now select the end point shown to extend the feature over the groove.



Traditional turning  | 89Get Started with ESPRIT

6. Click Cycle Stop to confirm the change.

7. Mask the solid model.

8. Change the view to Top and zoom in to the profiles.

9. Click Manual Chain again and select the chain on the ID profile.

10. Click Move Back and use Highlight mode to select the feature sub-element shown.
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11. Click Cycle Stop to confirm the change.

12. Select the ID feature and press Ctrl+C. Set Transformation Type to Smash and click OK to extract wireframe 
geometry from the chain. You will use a segment to create a simple chain feature for a threading operation at 
the front of the ID.

13. In the Feature Manager, double-click on G54 to activate the work coordinate. When you create a new feature, it 
will be created on this work coordinate.
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14. Use Highlight mode to select just the segment at the front of the ID and click Auto Chain.

15. In the Feature Manager, right-click on the new chain feature and then click Rename. Rename the feature Left 
I.D. Thread.
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Rough the face
You will use a roughing operation to quickly remove stock material on the face of the part. This is accomplished 
with linear cutting passes at incremental depths.
Roughing uses stock automation to identify areas where material needs to be removed. The system starts with the 
initial stock definition in Machine Setup and maintains awareness of all material removed by turning operations up 
to the current operation.
The feature on the face of the part is extremely short. However, this is not a problem because turning operations let 
you extend the toolpath to start cutting outside the bar stock and end at a point below the turning axis.

1. Press Ctrl+M and unmask Lathe Stock.

2. In the Feature Manager, select the feature Left Face. 

3. On the Smart toolbar, click Solidturn and then click Roughing.

4. Click System Default All to reset all parameters to the system defaults.

5. On the General tab:

• Operation Name = Face Rough

• Tool = OD Rough

• Speed CSS = 360 (speed and feed values are required)

• Feedrate PR = 0.1
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6. On the Strategy tab:

• Type of Work = Face

• End Extension = 16.5 (this value is measured from the end point of the feature to extend the toolpath below 
the centerline)

7. On the Rough tab:

• Stock Type = Automation (the system calculates the lathe stock automatically, starting from the initial bar 
stock)

• Rough Stock Z, X = 0, 0

• Maximum Depth of Cut = 2

• Lead-In Type = Tangent (since this is a face cut, it is better to lead in with a tangent move)

8. Click OK. Notice that the lathe stock is updated.

Rough the OD
When you rough the profile on the outer diameter, you will use a ProfitTurning strategy. ProfitTurning is a high-
speed roughing strategy that significantly reduces cycle times while increasing tool life. The ProfitTurning strategy 
blends trochoidal cutting passes with traditional linear passes. Arcs and trochoidal tool motion are inserted at 
sharp corners to maintain a constant tool load, which is ideal for hard material machining.

1. Select the feature Left OD. 

2. Click Roughing. You will use many of the parameters from the face roughing operation to rough the OD. ESPRIT 
retains the settings from the last roughing operation until you reset them.

3. On the General tab:

• Operation Name = OD Rough

• Tool = OD Groove R4 (The ProfitTurning strategy only supports circular inserts, such as this full radius 
groove tool)

• Speed CSS = 800

• Feedrate PR = .032
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4. On the Strategy tab:

• Type of Work = OD

• End Extension = 0

5. On the Rough tab:

• Rough Stock Z, X = 0.5, 0.5

• Rough Pattern = ProfitTurning - Parallel

• Maximum Depth of Cut = .5

• Min Trochoidal Radius, % = 2.0 (25%)

• Alternate Cut Direction = No (ProfitTurning supports zigzag motion in the toolpath)

• Lead-In Type = Normal

• Normal Distance = 0.2

• Lead-Out Type = None

6. Click OK. Notice the circular motion in the toolpath where the tool contacts corners and walls.

Dri l l  on the center l ine
To prepare for turning operations on the ID, you will first drill a hole that has the same diameter as the smallest 
diameter on the ID. Lathes are capable of drilling on the center line of the part. Lathes equipped with a Y axis are 
capable of off-center drilling. For this lesson, you will simply drill on the center line.

1. In the Feature Manager, select the feature Left I.D. Drilling. 
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2. Click Drilling.

3. Click System Default All.

4. On the General tab:

• Operation Name = Center Drill

• Tool = Drill 21 x 70L

• Speed RPM = 2000

• Feed Unit = Per Revolution

• Feedrate PR = 0.1

5. On the Drill tab, notice that Total Depth is automatically set to the depth of the feature.

6. Click OK. 

Rough and f inish the groove on the OD
The Grooving cycle lets you create rough and finish passes in the same operation. Rough passes in the Grooving 
cycle also support the ProfitTurning strategy. In this lesson, the groove is roughed with multiple plunge moves at 
80% of the width of the tool.
The finish pass is a contouring pass that follows the feature. In this case, the finish pass is split into two passes that 
start on each side of the groove and meet in the middle.

1. Select the feature Left Groove O.D.. 
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2. Click Grooving.

3. Click System Default All.

4. On the General tab:

• Operation Name = OD Groove

• Tool = OD Groove R1 W4

• Speed CSS = 800

• Feedrate PR = 0.032

5. On the Strategy tab, notice that Rough Pass and Finish Pass are both set to Yes.

6. On the Rough tab:

• Stock Type = Automation

• Rough Stock = 0.2, 0.2

• Groove Type = Multiple Plunge

• Step Over = 1.8 (Press the Tab key to calculate the percent of the tool diameter)

7. On the Finish tab:

• Finish CSS = 200

• Finish PM = 0.1

• Lead-In Type = Z and X Offset

• Offset Z, X = 0, 1.0

• Lead-Out Type = Z and X Offset

• Offset Z, X = 0, 1.0

8. Click OK. 
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Re-rough and f inish the OD
Roughing operations also let you create a single operation that includes roughing passes as well as a finish 
contouring pass. The same tool is used for entire operation.

1. Select the feature Left OD. 

2. Click Roughing.

3. On the General tab:

• Operation Name = OD Re-rough and Finish

• Tool = OD Groove R3

4. On the Strategy tab:

• Finish Pass = Yes (notice that the Finish tab displays)

5. On the Rough tab:

• Alternate Cut Direction = Yes

• Lead-In Type = Z and X Offset

• Offset Z, X = 0, 2

• Lead-Out Type = Z and X Offset

• Offset Z, X = 0, 2

6. On the Finish tab:

• Finish CSS = 800

• Finish PR = 0.032

• Lead-In Type = Tangent

• Tangent Distance = 2.0

• Lead-Out Type = Normal

• Normal Distance = 2.0

7. Click OK. 
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Rough and f inish the ID
You will use a roughing operation with standard incremental passes to rough and then finish the profile on the ID.

1. Select Left ID. 

2. Click Roughing.

3. Click System Default All.

4. On the General tab:

• Operation Name = ID Rough and Finish

• Tool = Rough 2H

• Speed CSS = 360

• Feedrate PR = 0.1

5. On the Strategy tab:

• Type of Work = ID

• Finish Pass = Yes

• Entry Mode = Z Only

• Entry Point Z = 5.0

• Exit Mode = Z Only

• Exit Point Z = 5.0

6. On the Rough tab:

• Stock Type = Automation

• Rough Stock Z, X = 0.2, 0.2

• Depth Variation = Even Steps

• Maximum Depth of Cut = 2

• Depth Clearance = 5

• Lead-In Type = None

• Lead-Out Type = None

7. On the Finish tab:

• Finish CSS = 360

• Finish PR = 0.1

• Tangent Distance (Lead-In) = 2

• Tangent Distance (Lead-Out) = 2
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8. Click OK. 

Groove the ID
This grooving operation uses a round insert to cut the groove on the ID with a ProfitTurning strategy. Instead of 
plunge moves, the toolpath is rounded. The approach/exit moves have been changed to cut on the ID.

1. Select Left Groove I.D.. 

2. Click Grooving.

3. On the General tab:

• Operation Name = ID Groove

• Tool = ID Groove R4

4. On the Strategy tab:

• Type of Work = ID

• Entry Mode = Z Then X

• Entry Point Z, X = 5, 9

• Exit Mode = X Then Z

• Exit Point Z, X = 5, 9

• Entry Exit Clearance = 1.0

5. On the Rough tab:

• Groove Type = ProfitTurning

6. On the Finish tab:

• Lead-In Offset Z, X = 0, 0

• Lead-Out Offset Z, X = 0, 0
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7. Click OK.

Thread the ID
Threading operations can be based on thread information that is entered manually or thread data can be loaded 
from an integrated threading database. In this operation, the threads will be created along the selected profile from 
manually entered data.

1. Select Left I.D. Thread. 

2. Click Threading.

3. Click System Default All.

4. On the General tab:

• Operation Name = ID Thread

• Tool = ID Thread

• Speed CSS = 360

• Feedrate PR = 0.1

5. On the Strategy tab:

• Entry Mode = Z Only

• Entry Point Z = 5.0

• Exit Mode = Z Only

• Exit Point Z = 5.0

• Clearance = .025

• Lead-Out Type = Chamfer (the lead-out will be angled)
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6. On the Thread tab:

• Thread Depth = 1.2

• Major Diameter = 34.4 (press the Tab key to automatically calculate the minor diameter)

• Threads/Lead = 2

• Start Length = 6 (the feature will be extended by 6 mm)

• End Length = -4 (a negative value shortens the feature)

• First Depth of Cut = 0.6 (press the Tab key to automatically calculate the number of rough passes)

• Multithread Cutting Mode = Per Thread Offset Start Angle (The two threads are each cut to full depth, but 
the second thread is offset by 180 degrees)

7. Click OK.

Per form a cutof f
The last step in this lesson is to separate the part from the bar stock.

1. Select the feature Left O.D.. The Cutoff operation will find the extremity point on the feature with the smallest Z 
value and use it as the start point for the operation

2. Click Cutoff.

3. Click System Default All.

4. On the General tab:
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• Operation Name = Cutoff

• Tool = Cutoff Tool (notice that you can only choose tools that have two cutting edges)

• Speed RPM = 1910

• Feedrate PM = 191

5. On the Rough tab:

• Rough to Diameter = -1 (the tool will cut slightly below the center line)

6. Click OK.
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Traditional milling

Lesson objectives
At the end of this lesson, you will know how to:

• Define milling stock

• Add milling tools

• Remove stock with pocketing and facing operations

• Drill holes

• Reorder operations

• Edit an operation in the Property Manager
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Impor t a mil l ing par t and get i t ready for machining
1. Start ESPRIT.

2. On the Tools menu, make sure System Unit is set to Metric.

3. Click File > Open.

4. Navigate to the lesson 06-Milling folder and open the file SumpPan.x_t.

5. On the Status bar, make sure HI mode and SUB-ELEMENTS mode are enabled.

6. If the UVW axis is not displayed, click UVW Axis on the View menu.

7. Rotate the model so you can see the pocket details. Notice the direction of the Z axis (blue axis). The pockets 
cannot be machined in the current orientation. You will quickly change the orientation of the model so that the 
tool can approach the pockets along the Z axis.

8. Use Highlight mode to select the top face of the model. 
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9. On the Edit menu, click Orient Part and then click Align Z to orient the face perpendicular to the Z axis. 

10. Set the window orientation to Isometric. 

Stock for milling operations is defined in Simulation Parameters. Stock can be defined as a block, a cylinder, from an 
extrusion or revolved profile, from a solid in the ESPRIT document, or from an external file. You will create stock as 
a rectangular block that is automatically sized to the outer dimensions of the solid model.

1. On the Smart toolbar, click Switch to SolidMill.

2. Click Simulation and then click Simulation Parameters. You will create simulation stock for this part.

3. Click the Solids tab. Currently there are no solids associated with this part.
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4. Make sure Type is set to Stock and Create From is set to Block. Click the selection arrow and then select the 
solid model in the graphics area. The dimensions of the model are loaded in the dialog.

5. Change Height to 37 to add 2mm of stock to the top of the model. 

6. Change the simulation color to blue and then click Add to create the simulation stock.

7. Click OK.
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8. On the Simulation toolbar, make sure Stock Visibility is enabled and then click Single Step to view the stock.

9. Click Stop to exit simulation mode.

Recognize mil l ing features
ESPRIT makes it easy to recognize milling features on an imported solid model.
Hole Feature Recognition recognizes all cylindrical openings (holes) in a solid model. Hole features are used for 
drilling operations.

1. On the Smart toolbar, click Features and then click Holes.

2. Click the arrow next to Max. Diameter and then select the edge of the center hole. 

3. Make sure Min. Diameter is set to 0.
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4. Click the arrow next to Min. Hole Opening Angle and then select the arc on the slot.

5. Set Propagate Hole Faces to Yes.

6. Set Active Work Plane Only to Yes.

7. Select the solid model and click OK. 

Three hole features are created and named automatically based on the hole type, diameter, and depth. The large 
hole in the center is recognized so it can be predrilled before it is milled.

When you have a solid model, you can use Pocket Feature Recognition to automatically recognize pockets and any 
sub-pockets or islands contained within them.

1. On the Features toolbar, click Pocket. 
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2. Select the solid model. The Feature Recognition Report displays. You are notified that Pocket Feature 
Recognition did not recognize the countersink holes.

3. Click OK in the Feature Recognition Report to create the pocket features.

Pocket features are created and associated with the active work plane. Notice that the large hole in the center is 
recognized. This hole is large enough to be milled. 

Mount tools on the mil l ing machine
For this lesson, you will need a face mill, end mills and drills. First you will create a 25 mm end mill for roughing.

1. In the Tool Manager, click Milling Tools and then select End Mill.
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2. Click System Default All.

3. On the General tab:

• Tool ID = EM 25

4. On the Settings tab:

• Turret Name = Head

• Axis Orientation = Z+

5. On the Shank tab:

• Shank Diameter = 25

6. On the Cutter tab:

• Tool Diameter = 25

7. Click OK. 
Next you will add a 10 mm end mill that will be used for finishing.

1. Click End Mill again.

2. On the General tab:

• Tool ID = EM 10

• Simulation Cut Color = Orange

3. On the Shank tab:

• Shank Diameter = 10

4. On the Cutter tab:

• Tool Diameter = 10

5. Click OK. 
Now you will add a face mill that uses the system defaults.

1. Click Face Mill.

2. Click System Default All.

3. On the General tab:

• Tool ID = Face Mill

4. On the Settings tab:



Traditional milling  | 111Get Started with ESPRIT

• Turret Name = Head

• Axis Orientation = Z+

5. On the Cutter tab:

• Notice that Face Mill tools allow the definition of inserts.

6. Click OK. 
You will import the rest of the tools from an ESPRIT Tool Library (*.etl) file. The library contains milling and drilling 
tools.

1. In the Tool Manager, click File > Open.

2. Open the file MillingTools.etl, located in your lesson folder. The tools are imported into the Tool Manager.

3. Right-click on the Dia./Rad. column heading and select Sort Descending so that the largest tool is placed at the 
top of the list. 
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4. Right-click inside the Tool Manager and select Advanced and then Renumber. 

5. In the dialog, click OK to renumber the tools based on their position in the tool list. 

Rough the pocket
ESPRIT offers two types of high-speed toolpath for pocketing operations: trochoidal and ProfitMilling. 
Trochoidal motion is always circular, so it works best on pockets without obstacles that will interrupt that circular 
motion.
ProfitMilling works well on this part because the pocket contains different internal shapes. ProfitMilling analyzes 
the shape of the pocket to apply a combination of trochoidal motion and offset motion in an optimal way. 

1. In the Feature Manager, select the Pocket feature set (displayed with a folder icon).

2. On the Smart toolbar, click SolidMill Traditional and then click Pocketing.

3. Click System Default All.
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4. On the General tab:

• Operation Name = Rough Pocket

• Rough Tool ID = EM 25

5. On the Strategy tab:

• Tool Motion Pattern = ProfitMilling (ProfitMilling creates highly optimized toolpath to reduce cycle time 
and extend tool life)

• Total Depth = 25

• Cut Speed RPM (Slotting Strategy) = 5000 (values for Slotting Strategy will be used in areas where 
trochoidal motion will not fit)

• XY Feedrate PM (Slotting Strategy) = 500

• Total Depth = 25

• Incremental Depth (Slotting Strategy) = 10

• Stock Automation = Yes (notice that some settings are now hidden from view because the Stock Automation 
engine in ESPRIT will calculate optimized toolpath for you based on the in-process stock model)

6. On the Rough tab:

• Cut Speed RPM = 5000

• XY Feedrate PM = 500

• Z Feedrate PM = 500

• Max Feedrate PM = 10000 (the maximum feedrate is used to limit the Transition Feedrate in trochoidal 
toolpath)

• Step Over % = 10% (press the Tab key and notice that the Engagement Angle is also updated)

• Stock Allowance Walls = 0.5

7. Click OK. Notice the areas of sweeping circular motion in the corners and the center of the pocket, combined 
with sweeping offset motion that follows the shape of the walls. The load on the cutter is consistent throughout 
the entire toolpath. 

Notice the toolpath on the top face above the pocket. Stock Automation detected stock on the top face because we 
forgot to create a facing operation first.
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Inser t an operation to face the top of the par t
You will now create a facing operation after the pocketing operation. That is not a problem because you can easily 
change the order of operations in the Operations Manager and stock automation will update the toolpath based on 
the true shape of the in-process stock.

1. In the Feature Manager, select 1 Boundary inside the Pocket feature.

2. Click Facing.

3. Click System Default All.

4. On the General tab:

• Operation Name = Facing

• Tool ID = Face Mill

• Cut Speed RPM = 10000

• XY Feedrate PM = 2000

• Z Feedrate PM = 2000

5. On the Strategy tab:

• Bridge Movement = Arcs

6. Click OK. 
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7. In the Operations Manager, select the Facing operation to highlight it in the list and then use your cursor to 
drag it above the Rough Pocket operation. A red line highlights the new placement of the operation.

8. Right-click on the Rough Pocket operation in the list and select Rebuild from the popup menu. The Pocketing 
toolpath is updated to recognize the stock removed by the Facing operation.

Finish the pocket
Now you will create a second pocketing operation to remove the rest of the material in the pocket with a smaller 
tool. This pocketing operation will use stock automation to create toolpath only in areas where stock remains from 
the previous, larger tool. The operation will also include finish passes on the walls.

1. Again, select the Pocket feature.

2. Click Pocketing.

3. On the General tab:

• Operation Name = Finish Pocket

• Wall Finish Pass = Yes (notice that a tab for Wall Finish now displays)

• Rough Tool ID = EM 10

• Wall Finish Tool ID = EM 10

4. On the Strategy tab:

• Incremental Depth = 25

• Stock Automation = Yes

5. On the Rough tab:

• Cut Speed RPM = 5000 (press the Tab key to automatically calculate the feedrate values)
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6. On the Wall Finish tab:

• Cut Speed RPM = 5000

• XY Feedrate PM = 500

• Z Feedrate PM = 500

• Lead-In/Out Type = Distance

7. Click OK. Notice that toolpath is created only in the corners and narrow areas where the 25 mm tool could not 
fit. Final, contouring passes are then applied to the walls. 

Spot dr i l l  and dri l l  the holes
This part has holes of different sizes. You will first drill a pilot hole in the center of each hole and then drill the 
smaller holes. 

1. In the Operation Manager, use the Shift key to select all the operations, right-click and select Hide. The 
toolpath is hidden in the graphics area.

2. In the Feature Manager, group 1 Simple Hole, 2 Simple Hole, and 3 Countersink. 

3. Click Drilling.

4. Click System Default All.
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5. On the General tab:

• Operation Name = Spot Drilling

• Tool ID = 5mm Drill

• Cut Speed RPM = 5000

• Z Feedrate PM = 500

6. On the Drill tab:

• Total Depth = 2.0

• Dwell = 2

7. Click OK. This operation is applied to all three hole features and the features are automatically grouped in a 
single folder (Feature Group) in the Feature Manager. 

8. In the Feature Manager, use the Ctrl key to group 1 Simple Hole and 3 Countersink. 

9. Click Drilling again.

10. On the General tab:

• Operation Name = Drilling

• Tool ID = 8mm Drill

• Cut Speed RPM = 5000 (press the Tab key to automatically calculate the feedrate)
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11. On the Drill tab:

• Cycle Type = Peck

• First Peck Increment = 10

• Peck Increment = 10

• Total Depth = Right-click on the value and select System Default to load the depth property from the 
features

• Tip Already Included = Yes

12. Click OK. 

13. The drill used for the countersink hole is too big. You can make simple edits to a machining operation in the 
Property Manager. In the Feature Manager, select to highlight the Drilling operation appled to 3 Countersink.

14. In the Property Manager, change Tool ID to 5mm Drill and press the Enter key. The operation is updated in the 
graphics area.

15. In the Feature Manager, group 2 Simple Hole. 
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16. Click Drilling.

17. Click System Default All.

18. On the General tab:

• Operation Name = Large Hole Drilling

• Tool ID = 20mm Drill

• Cut Speed RPM = 1500

• Z Feedrate PM = 200

19. Click OK. 

Countersink holes
1. Select the feature 3 Countersink and click Drilling.

2. Click System Default All.

3. On the General tab:

• Operation Name = Countersink

• Tool ID = Chamfer Mill

• Cut Speed RPM = 5000

• Z Feedrate PM = 500

4. On the Drill tab:

• Use Chamfer Diameter = Yes
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Mil l the slot
The ends of the slot have already been drilled. You can use those pre-drilled holes as the entry point for a pocketing 
operation.

1. In the graphics area, select 3 Pocket and then click Pocketing. 

2. Click System Default All.

3. On the General tab:

• Operation Name = Slotting

• Tool ID = EM 8

4. On the Strategy tab:

• Incremental Depth = 6

• Retract for IDepth = Partial Depth (retract moves are measured from the current cutting depth to keep the 
tool inside the slot)

5. On the Rough tab:

• Cut Speed RPM = 5000

• XY Feedrate PM = 500

• Z Feedrate PM = 500

• Entry Mode = Plunge at Point

• From Predefined Points = Yes

5. Click OK. The drilling depth is automatically determined from the feature and the shape of the tool.
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• Predefined Points = Click the selection arrow and then select the feature 1 Simple Hole in the graphics area

6. Click OK. 
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Traditional wire EDM

Lesson objectives
At the end of this lesson, you will know how to:

• Import a CAD model and define simulation stock

• Set up a generic wire EDM 

• Recognize EDM features

• Create contouring operations

• Use work coordinates to machine multiple copies of the same part

• Sort EDM operations
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Impor t an EDM par t and get i t ready for machining
1. Start a new session of ESPRIT.

2. On the Tools menu, make sure System Unit is set to Metric.

3. Click File > Open.

4. Navigate to the folder 07-EDM and open the file EDMPart.x_t.

5. On the Status bar, make sure HI mode and SUB-ELEMENTS mode are enabled.
This file contains two solid models: the part to be machined and a plate of rectangular stock. You will use the solid 
model of the plate to define the stock model. Stock for EDM operations is defined in Simulation Parameters.

1. On the Smart toolbar, click Switch to SolidWire.

2. Click Simulation and then click Simulation Parameters.

3. Click the Solids tab and set Definition Type to Stock and Create from to Solid.
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4. Click the arrow button and select the solid model of the plate. Change the color to a transparent blue and click 
Add.

5. Click OK.
You need to specify the type of EDM machine you will be programming. ESPRIT supports a variety of EDM machine 
types with specific technology for each unique machine. The machine type you choose determines the technology 
that is available when you create EDM operations.

1. On the Tools menu, click EDM Machine Types.

2. Select Generic and click OK.

The EDM Exper t System and User Database Files

The EDM Expert System is an essential function in ESPRIT that loads cut data for a particular type of machine onto 
an EDM technology page. Each machine manufacturer uses its own cut data. The Expert System saves time and 
reduces errors by allowing the user to enter values automatically.
ESPRIT uses a universal Expert System viewer that displays the data for any type of machine. Each machine, 
and each version of a machine, will have a different and unique XML file that contains data for that machine. The 
advantage of XML files is that they are small, easy to deploy, and easy to customize.
You can choose an EDM database file in EDM Machine Types.

The selected database is then opened by default when you click the Expert System button on a machining 
technology page. However, this is just the default database for your convenience. When you access the Expert 
System, you can decide to use any other database file that is available on your computer.
Database files can be downloaded from ESPRITWeb.
The default location for database files on your computer is C:\Users\username\Documents\DP Technology\
ESPRIT\Data\Technology
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Recognize EDM features
Draft Feature Recognition in ESPRIT is designed to create features specifically for wire EDM operations. The unique 
machining properties contained within draft features provide a single source of information for EDM operations.
This stock model has pre-drilled thread holes. You will extract the locations of the thread holes and use them when 
you define the EDM features. When EDM operations are applied to the features, the wire will always start at the 
thread location defined in the feature.

1. Hold down the Ctrl key and use HI mode to group the edges of the two holes shown below.

2. Press Ctrl+C and set Transformation Type to Smash.

3. Click OK. Geometry circles have been extracted from the selected edges. Now you can hide the stock model to 
make it easier to work on the part. 

4. Create a new layer and name it Stock.
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5. Group the solid model of the plate and change the Layer property to Stock.

6. Hide the Stock layer, select the Default layer, click Current and close the Layers dialog. 

Now you have everything you need to create EDM features.

1. Make sure the XYZ work plane is active. The W axis of the active work plane controls the vertical orientation of 
the wire. The height of the UV and XY planes are measured from the origin of the work plane. 

2. Drag a selection box around the entire model. There should be 3 elements in the group: the solid model and the 
two circles that represent the thread holes. 
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3. Click Features and then click Draft Features. 

4. Click System Default All to reset all parameters to the system defaults. 

5. Set Part Type to Hole. The system will only recognize the cylindrical opening in the model. 

6. Click the selection arrow next to Minimum Diameter and select the edge of the large hole. This will prevent the 
the system from creating hole features on the thread holes.

7. Click OK.

8. With the elements still grouped, click Draft Features again.

9. Set Part Type to Punch. Now the system will recognize the vertical walls and exclude cylindrical openings.
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10. Click the selection arrow next to Maximum Thread Diameter and select the circle outside the part.

11. Click OK.

12. In the Feature Manager, select the Punch feature.

13. In the Property Manager, select the property for Lead-In Point. The point highlights in the graphics area. Notice 
that the system chose the circle located on the outside of the solid model because Part Type was set to Punch. 

Program the par t
1. Select the Hole feature and then click SolidWire > Contouring. 

2. Click System Default All.

3. On the General tab:

• Operation Name = Hole

• Make sure Strategy is [Rough][Skim] and Cut-off Strategy is None
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4. Click the Cut Data tab.

5. Set Strategy to Rough and 1 Skim. 

6. For the Initial cut:

• Power = 951

• Feedrate = 2.0

7. For the Rough cut:

• Power = 951

• Feedrate = 2.0

• Offset = 0.1981

8. For the Skim 1 cut:

• Power = 1212

• Feedrate = 7.1

• Offset = 0.1422

9. Click OK to create the operation. The system creates one parent operation that includes two child operations: 
one rough and one skim cut. The icons are slightly different to identify each type of cut.

10. Select the Punch feature and click Contouring again.

11. On the General tab:

• Operation Name = Punch

• Primary Stop = Optional Stop

• Primary Distance = 5 (the cut-off tab will be measured 5 mm along the feature from the end point)
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12. On the Cut Data tab you will use the same settings as the previous operation. The system retains the last user 
settings until you reset them to the system defaults.

13. Click OK to create the operation. There are now 5 operations in the Operation Manager.

Copy operations to new work coordinates
Now that you have one part programmed, you will make five copies to machine a total of 6 identical parts.
Work coordinates, also called work offsets, simplify programming and setup when multiple copies of the same part 
are machined.

1. Press Ctrl+M and unmask Work Coordinate. Now work coordinates will display in the graphics area.

2. Right-click inside the Feature Manager and choose New Work Coordinate.

3. The spacing between each copy needs to be 22 mm. Change the X coordinate value to 22 and click OK.
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4. Create four more work coordinates with the following X locations:

• 3 Work Coordinate: X 44

• 4 Work Coordinate: X 66

• 5 Work Coordinate: X 88

• 6 Work Coordinate: X 110

5. In the Feature Manager, group the Hole and the Punch parent operations.

6. On the Edit menu, click Copy and set Transformation Type to Work Coordinate. Select Copy and then select 
Copy to All.
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Sor t EDM operations
In this lesson, the Hole is cut before the Punch. All the cut-offs should be last.

1. In the Operation Manager, right-click on the Name title and choose Sort Ascending. All the Hole operations are 
placed at the beginning of the list.

2. In the Operation Manager, group only the Punch operations.

7. Click OK. The operations and their associated features are copied to every work coordinate in the Feature 
Manager.
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3. Click Advanced Operation Sorting. 

4. In the dialog:

• Sort By = [Rough][Skim][Cut-off] (all roughs are cut first, then all skims, then all cut-offs)

• Insert Position = In Place

• Optimize First Cut-off = Yes (cut-offs will always re-thread at the drilled thread hole)

• Routine = Shortest Path

5. Click Apply to preview the sort criteria. Notice that rough cuts are first, then skims, then cut-offs.

6. Click OK to confirm the changes.
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Simulate EDM operations
1. Click Simulation and then Simulation Parameters. Make sure Stop Code is checked. Simulation will stop 

every time a stop code is encountered. Uncheck Automatic Slug Removal. You can manually simulate the slug 
drop for EDM operations.

2. Click Play to start the simulation.

3. Drag the Simulation Speed slider back and forth to change the simulation speed.

4. When the simulation stops at the first cut-off, click Play again to continue the simulation. 

5. On the Advanced Simulation toolbar, click Slug Removal. Choose various slugs in the list and click Move Up, 
Move Down, or Remove to test the removal of the slugs. When you are finished click OK.

6. Click Stop to exit simulation mode.
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